Homematic LAN Gateway wird nicht mehr gefunden

Dieser Beitrag bezieht sich auf das folgende Produkt: Homematic Funk-LAN Gateway HM-LGW-O-TW-W-EU für Smart Home / Hausautomation

Bestell-Nr. 68-10 40 29

Zum Produkt
zur Übersicht7 Beiträge Thema abonnieren Neue Antwort
Anzeigen  Sortieren 

Homematic LAN Gateway wird nicht mehr gefunden

von Michael K. » 31.01.2016, 22:14 

Guten Tag,

ich habe das Problem, dass das LAN.Gateway nach einem reboot der CCU2 nicht mehr gefunden wird. Im Log findet sich zuerst der Versuch, den Gateway einzubinden:

Jan 31 20:38:34 homematic-ccu2 user.info logger: Updating RF Lan Gateway Coprocessor Firmware
Jan 31 20:38:34 homematic-ccu2 user.debug update-coprocessor: firmware filename is: coprocessor_update.eq3
Jan 31 20:38:34 homematic-ccu2 user.info update-coprocessor: performGatewayCoproUpdate(): updating MEQ1479173
Jan 31 21:38:36 homematic-ccu2 user.info kernel: [ 41.350000] PHY: imx28-fec-1:00 - Link is Up - 100/Full
Jan 31 21:38:36 homematic-ccu2 user.info kernel: [ 41.360000] PHY: imx28-fec-1:00 - Link is Down
Jan 31 20:38:36 homematic-ccu2 user.err update-coprocessor: Could not find gateway by unicast with ip 192.168.178.29. Trying search by serial number.
Jan 31 20:38:44 homematic-ccu2 user.err update-coprocessor: Could not find Lan Gateway using ip and serial number
Jan 31 20:38:44 homematic-ccu2 user.err update-coprocessor: UnifiedLanCommController::connect(): Unable to connect.
Jan 31 20:38:44 homematic-ccu2 user.err update-coprocessor: Could not connect to Lan Gateway ip: 192.168.178.29.

das wird dann ein paar Sekunden später ein zweites Mal versucht und endet wieder in einem Fehler:

Jan 31 21:38:59 homematic-ccu2 user.crit rfd: CCU2LGWCommController::init(): Cannot connect to Homematic Lan Gateway with serial number MEQ1479173.

Außerdem kommen hier eine Menge Meldungen ala
PHY: imx28-fec-1:00 - Link is Up - 100/Full
PHY: imx28-fec-1:00 - Link is Down
usw.

Danach erst wird Netzwerkkarte der CCU2 aktiviert:

Jan 31 20:39:14 homematic-ccu2 daemon.info ifplugd(eth0)[209]: Link beat detected.
Jan 31 20:39:16 homematic-ccu2 daemon.info ifplugd(eth0)[209]: Executing '/etc/ifplugd/ifplugd.action eth0 up'.
Jan 31 20:39:16 homematic-ccu2 daemon.warn ifplugd(eth0)[209]: client: udhcpc (v1.20.2) started
Jan 31 20:39:17 homematic-ccu2 daemon.warn ifplugd(eth0)[209]: client: Sending discover...
Jan 31 20:39:17 homematic-ccu2 daemon.warn ifplugd(eth0)[209]: client: Sending select for 192.168.178.33...
Jan 31 20:39:17 homematic-ccu2 daemon.warn ifplugd(eth0)[209]: client: Lease of 192.168.178.33 obtained, lease time 864000
Jan 31 20:39:18 homematic-ccu2 daemon.warn ifplugd(eth0)[209]: client: rm: can't remove '/var/etc/resolv.conf': No such file or directory
Jan 31 20:39:18 homematic-ccu2 daemon.warn ifplugd(eth0)[209]: client: udhcpc (v1.20.2) started
Jan 31 20:39:19 homematic-ccu2 daemon.warn ifplugd(eth0)[209]: client: Sending discover...
Jan 31 20:39:19 homematic-ccu2 daemon.warn ifplugd(eth0)[209]: client: Sending select for 192.168.178.33...
Jan 31 20:39:19 homematic-ccu2 daemon.warn ifplugd(eth0)[209]: client: Lease of 192.168.178.33 obtained, lease time 864000
Jan 31 20:39:21 homematic-ccu2 daemon.info ifplugd(eth0)[209]: Program executed successfully.

Das kann nicht funktionieren: Das Gateway wird gesucht, bevor die Netzwerkkarte der CCU2 bereit ist.

Firmware der CCU2 ist aktuell (2.15.5)
Ist die CCU2 mal gebootet läuft sie absolut stabil.
Das Gateway hat die Adresse über DHCP
Das Gateway kann angepingt werden, Netzwerk ist stabil.

Was kann ich tun, damit das wieder geht?

Danke
Michael K.
Beiträge: 29
Registriert
09.01.2014

AW: Homematic LAN Gateway wird nicht mehr gefunden

von Michael K. » 01.02.2016, 23:07 

Nach weiterem Suchen stelle ich fest, dass hier offensichtlich ein Serienfehler der CCU2 vorliegt, da das selbe Fehlerbild bei verschiedensten Usern mit verschiedensten Netzwerken immer wieder mal auftritt:

http://www.elv.at/topic/ccu2-lan-verbindung-bricht-ab.html

http://www.elv.at/topic/ccu2-auf-neuem-switch-kein-link-auf-lan-port.html

Offensichtlich ist das Problem folgendes:
- Der Lan-Gateway wird nach dem Booten sehr bald abgefragt - zu einem Zeitpunkt zu dem das Netzwerk noch nicht bereit ist.
- Außerdem wird bei Herstellung der Netzwerkverbindung nicht nochmals versucht, eine Verbindung zum Gateway aufzubauen.

Dies lässt sich leicht testen, indem man das Netzwerkkabel abzieht. Die CCU erkennt den Netzwerkverlust (auch am LED ersichtlich). Beim Wiederherstellen der Netzwerkverbindung wird zwar selbige hergestellt, aber nicht die Verbindung zum LAN Gateway. Ergo: Er ist offline. Lässt sich im Log auch nachlesen.

Lösung wäre ganz einfach: Wenn die Verbindung zum Netzwerk hergestellt wird, auch das LAN Gateway suchen. Wäre schön, wenn das im nächsten Firmware Update behoben wird.
Michael K.
Beiträge: 29
Registriert
09.01.2014

AW: AW: Homematic LAN Gateway wird nicht mehr gefunden

von ELV - Technische Kundenbetreuung » 02.02.2016, 16:09 

Hallo Michael K.,

laut Hersteller eQ-3 wird bereits seit der CCU2 Firmware V2.13.2 die Verbindung mit dem LAN-Gateway automatisch wieder aufgebaut.

Hierbei ist es durchaus sinnvoll der Homematic CCU2 und dem LAN-Gateway jeweils eine feste IP-Adresse zu vergeben. Die IP-Adresse sollte zudem auch bei der Gateway-Konfiguration innerhalb der CCU2 im Feld "IP-Adresse (optional)" eingetragen werden.

Sollte es dennoch Herausforderungen geben, liegen diese vermutlich in der vorhandenen Netzwerkstruktur und den verwendeten Endgeräten (Router, Switches, PowerLine-Adapter, etc.) begründet. Es sollte dann zu Testzwecken ein "Minimal-Netzwerk" mit CCU2, LAN-Gateway und Switch aufgebaut werden, in dem das System auf korrekte Funktion überprüft werden kann.



ELV - Technische Kundenbetreuung
Beiträge: 12261
Registriert
01.07.2011
Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung

AW: AW: AW: Homematic LAN Gateway wird nicht mehr gefunden

von Michael K. » 04.02.2016, 21:06 geändert am 04.02.2016 21:10

Danke für die Antwort, auch für den Tipp mit den IP Adressen. Aber ich habe immer schon feste IP Adressen und selbige auch eingetragen.

Leider kann ich das Reconnect-Verhalten auf meiner CCU2 nicht nachvollziehen. Jeder Verbindungsversuch steht im Log, daher ist leicht nachvollziehbar, wie oft hier verbunden wird. Was ich sehe:

Wenn nach dem Booten der Gateway gefunden wird, dann wird auch nach einer Netzwerkunterbrechung der Gateway wieder gesucht (richtig)

Wenn aber beim Booten der Gateway nicht gefunden wird, dann wird auch später nicht mehr danach gesucht (falsch).

Letzteres ist bei mir der Fall - und vermutlich auch bei den anderen Kunden. Die Ursache ist offensichtlich, dass nach dem booten manchmal das Netzwerkinterface länger braucht, um sich zu aktivieren (erkennbar im log mit Up/down/Up/down/Up/down/Up Einträgen). Danach ist das Netzwerk (zumindest bei mir) stabil und bleibt up. Wenn im Bootprozess das Gateway erstmalig gesucht wird, ist es Glücksache, ob das Netzwerkinterface schon da ist oder nicht.

Reine Vermutung: Beim boot wird versucht das Gateway zu erreichen (und die Firmware des Gateways upgedated). Ist dies erfolgreich, wird ein Flag "Gateway vorhanden" gesetzt. Später, wenn die Netzwerkverbindung unterbrochen wird und dann wieder verbunden, wird "Gateway vorhanden" geprüft und wenn "ja", das Gateway neu verbunden. Wurde es aber erstmalig nicht gefunden, dann steht "Gateway gefunden" auf "nein", und es wird nie wieder ein Verbindungsversuch unternommen...

Aktuell geht es bei mir wieder - ich habe rebootet und laut Log war das Netzwerk jetzt schon up, als das Gateway erstmals gesucht wurde. Glück gehabt. (Ich habe diesmal nicht über die Software einen Neustart durchgeführt, sondern den Stromstecker gezogen. Das Hochfahren hat gefühlt länger gedauert. Dafür geht es jetzt).

Auch wenn es aktuell bei mir geht (was dafür spricht, dass es nicht an meiner Netzwerk-Konfiguration liegt), wäre es schön, wenn die Entwickler bei EQ3 da nochmals darüber könnten.
Michael K.
Beiträge: 29
Registriert
09.01.2014

AW: AW: AW: AW: AW: Homematic LAN Gateway wird nicht mehr gefunden

von ELV - Technische Kundenbetreuung » 02.03.2016, 10:06 geändert am 02.03.2016 10:15

Hallo Michael K.,

der Hersteller eQ-3 AG hat heute eine neue CCU2 Firmware (V 2.17.14) freigegeben, die u.a. einige Optimierungen der Netzwerkschnittstelle beinhaltet.

"...
[HMCCU2-868] Möglicher Verbindungsabriss zum Wired-Gateway gefixt.
[HMLGWOTWWEU-18] Stabilität des LAN-Gateways verbessert
[EQ3_SUPPORT-5] Stabilität CCU2 Netzwerk verbessert
..."

Details zum Firmware-Update finden Sie im Thread "Homematic CCU2 Firmware 2.17.14 verfügbar (mit Homematic IP Integration)".

Wir würden Sie daher bitten, die Firmware Ihrer Homematic CCU2 Zentrale zu aktualisieren und eine erneute Funktionsprüfung durchzuführen.

ELV - Technische Kundenbetreuung
Beiträge: 12261
Registriert
01.07.2011
Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung

AW: AW: AW: AW: AW: AW: Homematic LAN Gateway wird nicht mehr gefunden

von Michael K. » 04.02.2017, 17:29 

Der lieben Vollständigkeit halber: Habe das Update schon vor längerer Zeit eingespielt und kann bestätigen, dass das Problem behoben ist.

Vielen Dank. Schön, dass auf Kunden gehört wird.

Michael K.
Beiträge: 29
Registriert
09.01.2014
Anzeigen  Sortieren 
zur Übersicht7 Beiträge Neue Antwort